x79 DMG

Guide moved to the new site:

http://www.rampagedev.com/?page_id=48

72 Responses to x79 DMG

  1. nikje says:

    I found your website because I saw you have a working setup of MSI G41M-P26 + Lion. Do you have the DSDT for that one as well? If not, or if not needed, could you tell me how to install using that mainboard?

    Thanks,
    Nikje

  2. K.Swetank says:

    Sir, i am a newbie to this can you provide me a patched dsdt if i avail you with th raw dsdt. in order to install iAtkos L2 to my laptop…?? i have the New!Dell Inspirion 15R Special Edition…

  3. Ngoc Nguyen says:

    How talent he is.Thank you very very… much Rampage Dev , after he make me a new DSDT, my Mac ML never seen freaking random freezing again.

  4. Janus says:

    P9X79PRO- 2014BIOS: Clean install.
    Extra folder with
    org.chamaleont.Boot.plist+Themes+”On Board Nvidia” DSDT.aml
    AppleHDA.kext@KextDrop.app for audio
    What about Multibeast pic? Should i install all the checked options?
    Shouldn’t i use myHack-3.1.2 for kexts and Chamaleont?
    Thanks again

    • rampagedev says:

      What about Multibeast pic? Should i install all the checked options? Thats it. Then restart and you are done. You may need to added GraphicsEnabler=Yes to the boot.plist unless you plan to inject your GPU.

  5. Janus says:

    My graphic card is an Asus GeForce GTX480,
    I install all kexts AppleHDA.kext by Interim_Ivy_Bridge_Lion_AppleHDA as suggested in audio problem link ( I Haven’t S/L/E/ ALC8xxHDA, ALC8xx, HDAEnabler8xx)
    Copied DSDT (P9x79 PRO DSDT ver 1.3/2014BIOS/Nvidia/On board audio), all checked Multibeast option, but PS2 support (because i haven’t PS2).
    Edited chamaleont boo.plist with GraphicsEnabler=Yes
    But after 27 pages of code on grey background i got the PCI configuration error.
    I have also tried without GraphisEnabler flag, just because this flag didn’t work with the usb key boot, but i got the same error.
    BTW when I press a key for boot option in Chimera, i don’t see what i am typing, but -v works and i can see the boot code…

  6. Janus says:

    This is my boot file (i have added -v as in yoiur post, because the -v there was not in the dmg boot file):
    ********************************************************************************

    Kernel Flags
    -v npci=0x2000
    GraphicsEnabler
    Yes
    UseKernelCache
    No
    Timeout
    5

    ***********************************************************************************
    I have already installed extra folder, with DSDT (P9x79 PRO DSDT ver 1.3/2014BIOS/Nvidia/On board audio (and also tried HDMI audio)), then installed with kextDrop the AppleHDA.kext by Interim_Ivy_Bridge_Lion_AppleHDA and AHCIPortInjector.kext,
    all checked Multibeast option, except PS2 support (because i haven’t PS2).
    I always got it hanging at PCI config begin…
    As i have 2114 bios, I also tried with a copy of VoodooTSCSync.kext in the S/L/E and booted with “ignore cache”.
    Same error…

    Which operation so basic to any osx noob hacker i’m missing? πŸ˜€

  7. danell says:

    tried to install ML many times now but it always ends up with not wanting to boot after I have applied the DSDT.
    I have a Asus p9x79 with the latest driver.
    After the installation, Multibeast and your DSDT it starts, I come to Camelion but when I enter OSX it says “size 200. Incorrect image signature” and if I boot with -v it stops at “PCI configuration begin”. I have tried all npci=0x2000 and all that, from what I have read it says it’s about the DSDT. Can you help me?

  8. Janus says:

    Hi rampagedev, did you received my emails?

  9. sai says:

    Is there any DSDT for P8Z77-V ?

  10. Pasha says:

    Hey i have major problems configuring my new hackintosh build, read everywhere untill i stumbled here πŸ™‚

    My hardware
    i7-3930K
    Intel DX79TO LGA2011
    http://ark.intel.com/products/55800/Intel-Desktop-Board-DX79TO
    32 GB
    NVIDIA gtx 690
    ssd 128GB
    Raid 0 = 2TBX3 (unplugged the whole time)

    anyway i installed iatkos l2 with sucess and booted fine with verbose but have mouse lags, doesnt see my cpu, no graphics…so on…i decided to make a usb with ml2 to give it try which resulted in voodoo kexts being the last i saw and then darwin panic restart.
    tried every code possible doesnt change a damn thing…been trying to be up and running for video editing & afx work with no luck for a week already almost want to give up to windows again…

    cheers for any help!

  11. Jasjeet says:

    I’m pretty much up and running apart from some problem with audio and dsdt.

    P9X79 Pro, i7 3930k and HD5870 using top PCI port and DVI connection.
    System is usable until I install the dsdt, after I’m stuck at [PCI configuration begin]
    I’ve tried booting -v cpus=1 npci=0x2000 and 0x3000.

    Either get stuck at that point or end up at white screen.

    Any ideas?

  12. Jasjeet says:

    No need to reinstall, I removed the dsdt using transmac in windows and it boots fine.

    Now if I don’t use a dsdt I need to use the ALC898 patched AppleHDA.kext and a HDAEnabler. This combo isn’t working either yet.

    I’m using -v npci=0x2000 cpus=1

    I can see all the audio input/outputs but no sound =(

  13. Jasjeet says:

    I’m not on the latest bios, mainly because I’m a bit lazy and don’t want to setup my overclock settings again. I’m on v2104 currently.

    Would it be possible to get it to work on this version?
    Let me know and I will dump a fresh dsdt for you.

    Thanks

  14. vorsteh says:

    I have a Asus P9x79 pro board and I used to use Unibeast/MultiBeast to install everything. It was very hard to find the right combination of kext etc. When trying to update to 10.8.3 everything broke down. I was looking for alternatives and found your blog. After some beginners problems I understood the basics and it just got easier and easier. I did not follow all your instructions because I wanted to repair my Unibeast/Multibeast install. Anyway, now everything works just perfect except USB3. For me there is just one thing your guides are missing. After installing a new kext or whatever running myFix from myHack solved all my problems with sound and sleep.

    Thanks for a very useful blog and guides/tools. It is well worth a donation.

  15. TMAC says:

    ASUS recently released BIOS 4005 for the P9X79 series. Can anyone confirm if this is compatible? (I have the PRO version and care about it)

    the ASUS P9X79 download only contains DSDT for up to the 3009 BIOS.
    Also, which am I supposed to use? I have a NVDIA GeForce 650TI card.
    ATI/AMI HDMI Audio
    ATI/AMI OnBoard Audio
    Nvidia HDMI Audio
    Nvidia OnBoard Audio

    I suspect I use the Nvidia OnBoard Audio option?

    Thanks

  16. TMAC says:

    Any idea why my sound device is faint? I have it pegged all the way up and I can barely hear it in my headphones.

    Also, when will the multibeast graphic be updated for the latest version? It seems that some of the checked options are not necessarily options to be checked anymore.

    thanks again

    • rampagedev says:

      Not sure about the audio. You must be over looking something…

      As for Mutibeast I do not know what you are referring as it has nothing to do with my DMG.

  17. TMAC says:

    https://dl.dropbox.com/u/88732606/Asus/Asus%20DSDT.dmg.zip

    In this dmg zip file, there is a kext directory showing a bunch of stuff to add. There is a also a multibeast.png file showing a number of things to install with multibeast. It is an outdated image for an older version of multibeast. I was wondering when/if that image might be updated.

  18. TMAC says:

    Like I said, there is a newer version with some slightly different available options…I, as a newbie, am not sure if anything needs to be changed, and that is why I am asking in your forum.

    Thanks for your kind replies.

  19. Hung says:

    Hi all.
    I have a R4E with cpu E5-4650 ES and GTS 250.
    I install Mac OS 10.8.3 by myHark (I can’t install by UniBeat – turn off screen after boot).
    Everything work, only sound don’t work.
    In MultiBeat, If I check User DSDT then turn off screen after boot.
    I read DSDT but I can’t compile DSDT (error).

    Please, help me fix my DSDT (Attachmented).

    Thanks all.

    PS: Sorry, My English very bad.

    http://www.mediafire.com/download/dp8n25507z2p05b/dsdt.zip

  20. Dan says:

    I have the x79-ud3
    I’ve done the setup 3 times with the same result.
    It gets stuck on the buffer headers
    Any ideas?

  21. Erik says:

    Hello i am also having problem with the dsdt getting stuck on
    ” Mac framework successfully initialized
    Using 16384 buffer headers and 10240 cluster IO buffer headers”

    how would i go about fixing this?

  22. svsdiscussion says:

    I am thinking about buying a DX79SI. Do you think this MB is mackintosh-friendly?

  23. bf3portox says:

    attention P9X79 BIOS 4210 no work , stop in nullcpupowermanagent , I downgrade to P9X79 BIOS 4106 and work perfect.

    the reason can be Support Intel IVB-E series CPU???

    • rampagedev says:

      Sounds like a new DSDT extract is needed for the newer BIOS. Remove the DSDT from the extra folder and then update the BIOS if it boots report back and email me a DSDT extract. Please list the name of the board and BIOS version in the email.

  24. jontah says:

    Hi rampagedev!

    I’m using an Asus Sabertooth x79 motherboard with Intel 3930k processor.

    I’ve successfully installed Mavericks, but when trying to boot into the new OS I just CANNOT reach it. The computer just restarts itself over and over again. Not even reaching the apple loading logo with the spinning wheel.

    What should I do?

    I’ve tried all kinds of bootflags and combinations suchs as -v npci=0x3000 or npci=0x2000 -x and all other kinds of commands, I’ve tried literally 30-40 combinations, I kept trying over and over again yesterday. No luck at all.

    Please, ANY help is greatly appreciated!! I can’t get my computer to work after the update at all :/

    I’m using Chameleon as bootloader (I think) and u n i b e a s t though.

    I don’t have ANYTHING other than OSX installed on my computer, so I can’t enter windows or anything.

  25. jared says:

    Hi rampagedev, thanks so much for your work on this!

    The apple update app sneakily tricked me into updating to 10.9.2 yesterday and left me with a non-booting system. After some reading I unplugged my second monitor that was connected via mini-displayport and was able to get to the desktop. Everything but my audio and 2nd monitor seemed to be working correctly.

    I followed your guide for my motherboard / gpu combo (asus x79 sabertooth / ATI 7970) and updated the kexts, ssdt.aml and chameleon.

    I got audio back successfully and I can now boot with the second monitor plugged in, but I still lose the display on the second monitor once the boot loader gets going.

    I’ve been doing some reading and it seems that even people on apple products are having issues with mini display port but none of the solutions I saw applied to my osx86.

    I’m not sure where to go from here. Any recommendations?

    Thanks!

    J

    • rampagedev says:

      Its a issue with Apples drivers. Some people are having luck rolling back the drivers.

      • jared says:

        Thanks for the tip. I found that someone had linked the AMD kexts from a 10.9 install and tried to replace all of my 10.9.2 kexts with those but it had no effect for me :\ .

        I’ll keep mucking with it and post back here if I figure anything out.

      • jared says:

        I ended up installing the 10.9.3 beta build. That fixed my dual display issues. I was able to use the 10.9.2 audio script to get my audio working as well. Back in business.

  26. jas says:

    I updated the SSDT from your latest DMG, along with FakeSMC, APICPUPM, boot.plist and smbios and now get stuck on the PCI Configuration Screen. And right before that it says my max turbo freq is 5700…

    Whats gone wrong here? I did change motherbaord, but it actually atleast booted with the old P9X79 Pro SSDT in place, now neither work from the DMG.

    Heres the specs that have changed
    3960X, P9X79 Pro -> 3960X, Rampage Gene IV

    Ideas?

  27. rampagedev says:

    We fixed the issues πŸ˜‰ The issue edit is SSDT-3 in the Beta folder on the DMG.

  28. osxfr33k says:

    Well after some exhaustive tests I have figured out how to get WAKE to work for the X79-Deluxe. Under AI Tweaker Disable CPU PLL Termination. This is set to Auto by default. Thanks to Rampage Dev for proper sleep/wake script in SSDT because without that it would not work at all.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s